RAPIDS + pip

Install Now

RAPIDS is back on Pip

RAPIDS users can once again install RAPIDS via pip! This is an experimental release supporting single GPU usage. cuDF, dask-cuDF, cuML, cuGraph, RMM and RAFT release 22.10 pip packages are available right now. The team is excited to get these packages out into the wild and see how the RAPIDS community uses them!

If you find issues, please file them in the respective RAPIDS Repositories.

Installing RAPIDS via pip


OS: One of the following OS versions:

Ubuntu 18.04/20.04 or CentOS 7 / Rocky Linux 8 with gcc/++ 9.0+

Windows 11 using WSL2 See separate install guide

In addition, WSL2 pip installations require following this guide to install the CUDA Toolkit without drivers.

Glibc version: x86_64 wheels require glibc >= 2.17 and ARM architecture (aarch64) wheels require glibc >= 2.31 (only ARM Server Base System Architecture is supported).

GPU: Only GPUs with Compute capability 6.0 or higher (i.e. Pascal generation or newer) are supported.

CUDA >= 11.5, with at least the v495.29.05 driver. To use CUDA 11.2, 11.3, or 11.4, please see Troubleshooting and Known Issues.

Python and pip version: Python 3.8 or 3.9 using pip 20.3+ with PEP600 support.


Join our community conversations about RAPIDS and pip using Twitter, Slack, or ask a question on StackOverflow.

If you find issues, please file them in the respective RAPIDS repo:

cuDF | cuML | cuGraph | RMM | RAFT

Installation Commands

pip install cudf-cu11 dask-cudf-cu11 --extra-index-url=https://pypi.ngc.nvidia.com
pip install cuml-cu11 --extra-index-url=https://pypi.ngc.nvidia.com
pip install cugraph-cu11 --extra-index-url=https://pypi.ngc.nvidia.com

The RAPIDS pip packages are hosted on the NVIDIA NGC index today.

On ARM architecture (aarch64), cupy needs to be installed separately:

pip install cupy-cuda11x -f https://pip.cupy.dev/aarch64

Troubleshooting and Known Issues

When installing these packages with CUDA 11.2, 11.3, or 11.4, you may experience a “Failed to import CuPy” error. To resolve this error, please uninstall cupy-cuda115 and install cupy-cuda11x:

pip uninstall cupy-cuda115; pip install cupy-cuda11x

The following error message indicates a problem with your environment:

ERROR: Could not find a version that satisfies the requirement cudf-cu11 (from versions: 0.0.1, 22.10.0)
ERROR: No matching distribution found for cudf-cu11

Check the suggestions below for possible resolutions.

Your Python version must be 3.8 or 3.9.

RAPIDS pip packages require a recent version of pip that supports PEP600. Some users may need to update pip:

pip install -U pip

Infiniband is not supported yet in this release

These packages are not compatible with Tensorflow pip packages. Please use the NGC containers or conda packages instead.

Dask / Jupyter / Tornado 6.2 dependency conflicts can occur. Install jupyter-client 7.3.4 if the error below occurs:

  ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
  jupyter-client 7.4.2 requires tornado>=6.2, but you have tornado 6.1 which is incompatible.